Applies To

Products that use DJI GO / DJI GO 4 app with a wired connection.


Problem

No Picture in Application.


Cause

  • The drone, app or radio has not been updated
  • Defective USB Cable
  • Defective USB port on either radio or tab / phone


Solution

  • Update app and firmware.
  • Try a different USB cable
  • Try a different phone / tab
  • If the steps above does not solve you problem, please contact us for further assistance.